Issue
Sometimes, consulting source data on an entity does not show any data and throws an "Unexcepted server error: An internal server error occurred"


Cause

If pde logs show errors that look like

Caused by: com.semarchy.mdm.runtime.model.logical.exception.NoSuchEntityException: No IEntity identified by CustomerAccountDetails in CustomerMaster

it might be caused by a modification of the entity name posterior to data import. And therefore, the same entity has multiple "classname" in database, causing the issue.

 

b_classname in higher version is case sensitive. 
For example, for entity Person, the tables contained the records with b_classname as Person and having some record with classname PERSON will also give same error.



This can be checked with a simple query like

select distinct(b_classname) from sd_<entity>


If this command shows multiple classnames, please identify the correct classname and rename or delete records with old classname(s).


UPDATE sd_<entity>
SET b_classmane = <desired_classname>
WHERE b_classanme = <unwanted_old_classname>

or

DELETE FROM sd_<entity>
WHERE b_calssname = <unwanted_old_classname>;